//
you're reading...
Openfiler, VMwire Lab

How to setup Active Directory authentication on Openfiler

Setup Active Directory Authentication

The steps must be performed in this order, otherwise you’ll get a headache trying to work out why you cannot see any Groups listed.

Go to Services | Enable SMB/CIFS server.

Click on SMB/CIFS Setup.

  1. Change the NetBIOS name to just the hostname of the server (do not include the domain).

Navigate to Accounts | Expert View. Configure for your environment, note the CAPITALIZATION of some of the fields.

Click on Use Kerberos 5 and enter your domain details, note the CAPITALIZATION of some of the fields.

Now click on Accounts | Group List and if done successfully, you should see your Domain groups.

Advertisements

About Hugo Phan

@hugophan

Discussion

7 thoughts on “How to setup Active Directory authentication on Openfiler

  1. Still it’s not working………..

    Posted by ruwan | November 17, 2011, 11:03
  2. Works like a charm, although the Openfiler server needed a reboot to show the users / groups from the active directory. Thanks!

    Posted by Staatslot | February 25, 2012, 14:35
  3. Worked great on Windows 2003 AD, with a gazillion OUs.
    Was a bit worried if everything will be compatible with everything else, and also my company’s AD is like 8 years old, spans 5 countries and has lots and lots of users…. Openfiler was pulling the user/group info for almost 10 minutes, but it looks like it coped, now I have 76 pages of groups, and almost 400 pages of users 😛

    Thanks for the write-up 🙂

    Posted by Stan | May 16, 2014, 10:01
  4. I wasted several days to get this working with different NAS-OS and an Windows Server 2012 R2 with AD.

    My conclusion:

    – Freenas: doesn’t work, users and groups are imported, samba just don’t like them.
    – Openmediavault: doesn’t work. same as Freenas
    – Openfiler: works like a charm. THX for your how-to!!!

    I wish i would’ve started with this one…

    Posted by Knutowskie | July 29, 2014, 11:06
  5. Perfect!!! thanks a lot!!!

    Posted by Infierno!!! (@ryoga121) | June 2, 2017, 20:00

Trackbacks/Pingbacks

  1. Pingback: New Openfiler for the VMwire lab « VMwire - June 13, 2011

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: